Errore aggiornamento WordPress dalla 2.9.2 alla 3.0 o 3.0.1 o 3.04

Oggi dopo l’aggiornamento italiano automatico alla versione 3.0 di WordPress, qualsiasi pagina richiamassi nel browser ottenevo il seguente messaggio d’errore:

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 30720 bytes) in /home/mhd-01/www.sullamaca.it/htdocs/wp-admin/includes/template.php on line 3755

Per evitare questo brutto messaggio occorre modificare un file di configurazione di WordPress. Il file da modificare è wp-config.php, andando dal proprio pannello di controllo sul file manager ed editarlo. Occorre introdurre la seguente riga di comando:

define(‘WP_MEMORY_LIMIT’, ’64M’);

L’ho inserita dopo le righe di comando “define” del database e dell’host. E’ sufficiente riaggiornare la pagina dove era visualizzato l’errore e tutto riprenderà a funzionare, come prima dell’aggiornamento alla versione di WordPress 3.0.

Se qualcuno invece di editare direttamente la riga vuole fare il “copia e incolla” della riga di comando sopracitata, prestare attenzione agli apici che siano trasformati correttamente.

Colgo l’occasione per ringraziare Gidibao, il suo forum per il supporto e la Zia Loretta.

P.S.
Se si ha un blog dal provider Aruba, dopo aver finito l’aggiornamento di WordPress 3.0 è necessario seguire dei passi operativi ulteriori, altrimenti il blog andrà in errore. L’errore che potrebbe essere visualizzato è:

INTERNAL ERROR, o error 500

L’errore generato riguarda i permessi sulla cartelle del vostro WordPress installato presso Aruba.
Per risolvere potete leggere le istruzioni di questo post del blog: http://www.tech-nology.it/?p=1278

14 commenti per Errore aggiornamento WordPress dalla 2.9.2 alla 3.0 o 3.0.1 o 3.04 o 3.1

  • Ok grazie Enrico ti farò sapere se anch’io sarò fortunato come te !

  • Io ho cercato di modificare il file wp config.php ma dopo l’aggiornamento si è presentato lo stesso il problema 500, va bene che posso farlo dal pannello di aruba, ma visto che gestisco una 20 di siti e aumenteranno ogni volta farlo manuale è un pò un casino, se ci fosse qualche opzione che lo faccia in automatico sarebbe fantastico !

    • Grazie della tua nota, non saprei se esite un tool di quel tipo. Devo dire che dalla versione 3.x in poi non si é più presentato l’errore, almeno nelle mie installazioni.

  • Enrico1968

    @ Umberto ho aggiornato la mia versione di WordPress dalla 3.01 alla 3.04 molto facilmente e senza errori. Tutto bene questa volta.

  • Enrico1968

    Ciao Umberto, devo dire che a parte l’errore segnalato i siti in WordPress che ho aggiornato non hanno subito alcun problema. Tieni presente che non ho ancora aggiornato alla 3.0.2 e 3.0.3.
    Ti consiglio di fare una copia del database, esportare in xml tutti i post e salvarti l’intera struttura del sito in locale via ftp. Prima di procedere all’avanzamento di versione è conveniente disattivare tutti i plugin e poi riattivarli uno a uno.
    Magari controlla prima se il tema che stai usando è compatibile con le versioni successive di WP.
    Fammi sapere.

  • Umberto

    Salve Ragazzi,

    ho un blog attualmente con WordPress 2.9.2 e vorrei aggiornarlo ma la mia preoccupazione è la perdita dei dati o dei plugin installati dopo l’aggiornamento. Qualcuno di voi l’ha già fatto e mi sa dire come e cosa fare di precise per evitare di perdere tutto…si tratta di un blog fotografico e perciò il mio timore è perdere anche e sopratutto le foto.
    Grazie Mille

    P.S
    Non ho capito il discorso dei permessi quando si aggiorna..potreste spiegarmi meglio?

  • Grazie Enrico,
    dopo alcuni tentativi di aggiornamento alla versione 3.0.1 di wordpress che presentavano il problema segnalato (mancanza del tasto aggiorna all’interno della creazione/modifica degli articoli), ho per puro caso notato che il tutto veniva ripristinato commutanto la presentazione della pagina su due colonne per poi ritornare su una colonna nelle opzioni attivabili tramite cartella “impostazioni Schermo”.

    Non riesco a spiegarmi il motivo, ma adesso la sezione “aggiornamento” viene presentata correttamente.

    Grazie comunque dell’interessamento.

  • Ho aggiornato WordPress da 2.9.2 a 3.0.1 utilizzando la funzione di upgrade automatico del pannello di amministrazione.
    Al termine dell’installazione, avvenuta senza segnalazione di anomalia, ho notato la mancanza della sezione “Pubblica” nel pannello di modifica o creazione degli articoli, impedendo così la creazione o la modifica di articoli del sito.

    Sapete se è un problema noto e come eventualmente ovviare al problema?

    Ringrazio anticipatamente.

    • Enrico1968

      Grazie d’aver scritto qui Giacomo. Francamente è la prima volta che sento di questa anomalia, forse dipende dal tema che utilizzi. Hai provato ad utilizzare il tema standard e vedere se ritrovi questo errore? Eventualmente potresti iscriverti e porre il problema nel forum di Gidibao che è un luogo amichevole per WordPress! 😉 Trovi informazioni qui:

      Fammi sapere.

  • ah ok ancora io non ho aggiornato,
    Ma 32M non bastavano vero? perche’ mi sa che aumentando troppo la memoria si abbassano le prestazioni poi dipende dall’hosting.
    ciao

    • Enrico1968

      Grazie del tuo commento. Si, dipende dall’hosting, nelle mie installazioni di WordPress che gestisco non ho notato abbassamenti di prestazioni. Cmq io lavoro con Tophost e ho dovuto portare a 64Mb ma va bene così. Ultima nota, stai attento riportare esattamente gli apici “giusti” nel file… Ciao e buon aggiornamento.

  • Vito

    Grazie mille… chiaro ed efficacissimo!!!!

Lascia un commento

Puoi usare questi tag HTML

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>